Skip to content

← Actionable
Unrated

Symfony Denial of Service Via Long Password Hashing

CVE-2013-5958GHSA-cr49-fx2v-9p57

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/polyfill 1.10.0; symfony/symfony 2.3.6, 2.2.9, 2.1.13, 2.0.25; symfony/security 2.3.6, 2.2.9, 2.1.13, 2.0.25), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist symfony/polyfill

    Affected
    >= 1.0.0, < 1.10.0
    Fixed in
    1.10.0
  • Packagist symfony/symfony

    Affected
    >= 2.0.0, < 2.0.25>= 2.1.0, < 2.1.13>= 2.2.0, < 2.2.9>= 2.3.0, < 2.3.6
    Fixed in
    2.0.25, 2.1.13, 2.3.6, 2.2.9
  • Packagist symfony/security

    Affected
    >= 2.0.0, < 2.0.25>= 2.1.0, < 2.1.13>= 2.2.0, < 2.2.9>= 2.3.0, < 2.3.6
    Fixed in
    2.0.25, 2.1.13, 2.3.6, 2.2.9

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-cr49-fx2v-9p57 lists affected ranges: Packagist symfony/symfony >=2.0.0 =2.1.0 =2.2.0 =2.3.0 =1.0.0 =2.0.0 =2.1.0 =2.2.0 =2.3.0 <2.3.6

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2013-5958: 1.87% estimated exploitation activity in the next 30 days; percentile 79.35 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Security component in Symfony 2.0.x before 2.0.25, 2.1.x before 2.1.13, 2.2.x before 2.2.9, and 2.3.x before 2.3.6 allows remote attackers to cause a denial of service (CPU consumption) via a long password that triggers an expensive hash computation, as demonstrated by a PBKDF2 computation, a similar issue to CVE-2013-5750.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-cr49-fx2v-9p57

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2013-5958

Advisory: Symfony Denial of Service Via Long Password Hashing
IDs: CVE-2013-5958, GHSA-cr49-fx2v-9p57
Record: https://patchnext.com/advisories/cve-2013-5958 (revision 1, source checked 26 Oct 2026, 14:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/polyfill 1.10.0; symfony/symfony 2.3.6, 2.2.9, 2.1.13, 2.0.25; symfony/security 2.3.6, 2.2.9, 2.1.13, 2.0.25. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/polyfill: affected >= 1.0.0, < 1.10.0; fixed in 1.10.0
- Packagist symfony/symfony: affected >= 2.0.0, < 2.0.25; >= 2.1.0, < 2.1.13; >= 2.2.0, < 2.2.9; >= 2.3.0, < 2.3.6; fixed in 2.0.25, 2.1.13, 2.3.6, 2.2.9
- Packagist symfony/security: affected >= 2.0.0, < 2.0.25; >= 2.1.0, < 2.1.13; >= 2.2.0, < 2.2.9; >= 2.3.0, < 2.3.6; fixed in 2.0.25, 2.1.13, 2.3.6, 2.2.9

## Suggested inspection (read-only)
- Packagist symfony/polyfill: check the installed version with your package manager.
- Packagist symfony/symfony: check the installed version with your package manager.
- Packagist symfony/security: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/polyfill, symfony/symfony, symfony/security.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-cr49-fx2v-9p57 (GitHub-reviewed advisory GHSA-cr49-fx2v-9p57 lists affected ranges: Packagist symfony/symfony >=2.0.0 =2.1.0 =2.2.0 =2.3.0 =1.0.0 =2.0.0 =2.1.0 =2.2.0 =2.3.0 <2.3.6)

Commands are suggestions: review each one before running it.

Loading voting…