Apache XML Security For Java vulnerable to Infinite Loop
CVE-2013-5823GHSA-8gwc-x7mg-7p7p
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.santuario:xmlsec 1.5.3, 1.4.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.santuario:xmlsec
- Affected
- >= 1.4.0, < 1.4.8>= 1.5.0, < 1.5.3
- Fixed in
- 1.4.8, 1.5.3
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8gwc-x7mg-7p7p lists affected ranges: Maven org.apache.santuario:xmlsec >=1.4.0 =1.5.0 <1.5.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2013-5823: 4.73% estimated exploitation activity in the next 30 days; percentile 91.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Affected versions of xmlsec are subject to a denial of service vulnerability. Should a user check the signature of a message larger than 512 MB, the method expandSize(int newPos) of class org.apache.xml.security.utils.UnsyncByteArrayOutputStream goes in an endless loop. A remote attacker could use this flaw to supply crafted XML that would lead to a denial of service.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8gwc-x7mg-7p7p
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2013-5823 Advisory: Apache XML Security For Java vulnerable to Infinite Loop IDs: CVE-2013-5823, GHSA-8gwc-x7mg-7p7p Record: https://patchnext.com/advisories/cve-2013-5823 (revision 1, source checked 26 Oct 2026, 16:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.santuario:xmlsec 1.5.3, 1.4.8. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.santuario:xmlsec: affected >= 1.4.0, < 1.4.8; >= 1.5.0, < 1.5.3; fixed in 1.4.8, 1.5.3 ## Suggested inspection (read-only) - Maven org.apache.santuario:xmlsec: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.santuario:xmlsec. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8gwc-x7mg-7p7p (GitHub-reviewed advisory GHSA-8gwc-x7mg-7p7p lists affected ranges: Maven org.apache.santuario:xmlsec >=1.4.0 =1.5.0 <1.5.3) Commands are suggestions: review each one before running it.
Loading voting…