Skip to content

← Actionable
Unrated

Code injection in dragonfly gem

CVE-2013-5671GHSA-qrgf-jqqm-x7xv

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems fog-dragonfly

    Affected
    <= 0.9.15
    Fixed in
    no fixed version recorded
  • RubyGems dragonfly

    Affected
    < 1.0.0
    Fixed in
    1.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2013-5671: 2.19% estimated exploitation activity in the next 30 days; percentile 82.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

lib/dragonfly/imagemagickutils.rb in the fog-dragonfly gem 0.8.2 for Ruby allows remote attackers to execute arbitrary commands via unspecified vectors.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-qrgf-jqqm-x7xv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2013-5671

Advisory: Code injection in dragonfly gem
IDs: CVE-2013-5671, GHSA-qrgf-jqqm-x7xv
Record: https://patchnext.com/advisories/cve-2013-5671 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: dragonfly 1.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems fog-dragonfly: affected <= 0.9.15
- RubyGems dragonfly: affected < 1.0.0; fixed in 1.0.0

## Suggested inspection (read-only)
- RubyGems fog-dragonfly: check the installed version with your package manager.
- RubyGems dragonfly: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on fog-dragonfly, dragonfly.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-qrgf-jqqm-x7xv (GitHub-reviewed advisory GHSA-qrgf-jqqm-x7xv lists affected ranges: RubyGems dragonfly >=0 =0 <=0.9.15)

Commands are suggestions: review each one before running it.

Loading voting…