Sounder Contains Arbitrary Command Execution Vulnerability
CVE-2013-5647GHSA-rfmf-rx8w-935w
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sounder 1.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems sounder
- Affected
- < 1.0.2
- Fixed in
- 1.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rfmf-rx8w-935w lists affected ranges: RubyGems sounder >=0 <1.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2013-5647: 1.99% estimated exploitation activity in the next 30 days; percentile 80.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
lib/sounder/sound.rb in the sounder gem 1.0.1 for Ruby allows remote attackers to execute arbitrary commands via shell metacharacters in a filename.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-rfmf-rx8w-935w
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2013-5647 Advisory: Sounder Contains Arbitrary Command Execution Vulnerability IDs: CVE-2013-5647, GHSA-rfmf-rx8w-935w Record: https://patchnext.com/advisories/cve-2013-5647 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sounder 1.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems sounder: affected < 1.0.2; fixed in 1.0.2 ## Suggested inspection (read-only) - RubyGems sounder: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sounder. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-rfmf-rx8w-935w (GitHub-reviewed advisory GHSA-rfmf-rx8w-935w lists affected ranges: RubyGems sounder >=0 <1.0.2) Commands are suggestions: review each one before running it.
Loading voting…