Skip to content

← Actionable
Critical, CVSS 9.5amended

graphite-web is vulnerable to Remote Code Execution via renderLocalView function

CVE-2013-5093GHSA-m923-w2gj-v43g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (graphite-web 0.9.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.5 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:H/VI:H/VA:H/SC:H/SI:H/SA:H · score source
EPSS
  • CVE-2013-5093: 38.67% estimated exploitation activity in the next 30 days; percentile 98.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The renderLocalView function in render/views.py in graphite-web in Graphite 0.9.5 through 0.9.10 uses the pickle Python module unsafely, which allows remote attackers to execute arbitrary code via a crafted serialized object.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-m923-w2gj-v43g

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-m923-w2gj-v43g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2013-5093

Advisory: graphite-web is vulnerable to Remote Code Execution via renderLocalView function
IDs: CVE-2013-5093, GHSA-m923-w2gj-v43g
Record: https://patchnext.com/advisories/cve-2013-5093 (revision 3, source checked 26 Oct 2026, 13:17 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.5)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: graphite-web 0.9.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI graphite-web: affected >= 0.9.5, <= 0.9.10; fixed in 0.9.11

## Suggested inspection (read-only)
- `python -m pip show graphite-web`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on graphite-web.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-m923-w2gj-v43g (OSV record GHSA-m923-w2gj-v43g lists affected ranges: PyPI graphite-web >=0.9.5 <0.9.11 (fixed))
- Verified: https://github.com/advisories/GHSA-m923-w2gj-v43g (GitHub-reviewed advisory GHSA-m923-w2gj-v43g lists affected ranges: PyPI graphite-web >=0.9.5 <=0.9.10)

Commands are suggestions: review each one before running it.

Loading voting…