Skip to content

← Actionable
Medium, CVSS 6.1

Symfony Host Header Injection vulnerability in the HttpFoundation component

CVE-2013-4752GHSA-22pv-7v9j-hqxp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 2.3.3, 2.2.5, 2.1.12, 2.0.24; symfony/http-foundation 2.3.3, 2.2.5, 2.1.12, 2.0.24), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist symfony/symfony

    Affected
    >= 2.0.0, < 2.0.24>= 2.1.0, < 2.1.12>= 2.2.0, < 2.2.5>= 2.3.0, < 2.3.3
    Fixed in
    2.1.12, 2.3.3, 2.0.24, 2.2.5
  • Packagist symfony/http-foundation

    Affected
    >= 2.0.0, < 2.0.24>= 2.1.0, < 2.1.12>= 2.2.0, < 2.2.5>= 2.3.0, < 2.3.3
    Fixed in
    2.1.12, 2.3.3, 2.0.24, 2.2.5

Sources

  • GitHub Advisory Database and maintainer security advisories on GitHub

    GitHub-reviewed advisory GHSA-22pv-7v9j-hqxp lists affected ranges: Packagist symfony/symfony >=2.0.0 =2.1.0 =2.2.0 =2.3.0 =2.0.0 =2.1.0 =2.2.0 =2.3.0 <2.3.3

    VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2013-4752: 2.31% estimated exploitation activity in the next 30 days; percentile 83.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Symfony 2.0.X before 2.0.24, 2.1.X before 2.1.12, 2.2.X before 2.2.5, and 2.3.X before 2.3.3 have an issue in the HttpFoundation component. The Host header can be manipulated by an attacker when the framework is generating an absolute URL. A remote attacker could exploit this vulnerability to inject malicious content into the Web application page and conduct various attacks.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-22pv-7v9j-hqxp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2013-4752

Advisory: Symfony Host Header Injection vulnerability in the HttpFoundation component
IDs: CVE-2013-4752, GHSA-22pv-7v9j-hqxp
Record: https://patchnext.com/advisories/cve-2013-4752 (revision 1, source checked 26 Oct 2026, 14:16 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 2.3.3, 2.2.5, 2.1.12, 2.0.24; symfony/http-foundation 2.3.3, 2.2.5, 2.1.12, 2.0.24. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist symfony/symfony: affected >= 2.0.0, < 2.0.24; >= 2.1.0, < 2.1.12; >= 2.2.0, < 2.2.5; >= 2.3.0, < 2.3.3; fixed in 2.1.12, 2.3.3, 2.0.24, 2.2.5
- Packagist symfony/http-foundation: affected >= 2.0.0, < 2.0.24; >= 2.1.0, < 2.1.12; >= 2.2.0, < 2.2.5; >= 2.3.0, < 2.3.3; fixed in 2.1.12, 2.3.3, 2.0.24, 2.2.5

## Suggested inspection (read-only)
- Packagist symfony/symfony: check the installed version with your package manager.
- Packagist symfony/http-foundation: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on symfony/symfony, symfony/http-foundation.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-22pv-7v9j-hqxp (GitHub-reviewed advisory GHSA-22pv-7v9j-hqxp lists affected ranges: Packagist symfony/symfony >=2.0.0 =2.1.0 =2.2.0 =2.3.0 =2.0.0 =2.1.0 =2.2.0 =2.3.0 <2.3.3)

Commands are suggestions: review each one before running it.

Loading voting…