Symfony collectionCascaded and collectionCascadedDeeply fields security bypass
CVE-2013-4751GHSA-q8j7-fjh7-25v5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 2.3.3, 2.2.5, 2.1.12, 2.0.24; symfony/validator 2.3.3, 2.2.5, 2.1.12, 2.0.24), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/symfony
- Affected
- >= 2.0.0, < 2.0.24>= 2.1.0, < 2.1.12>= 2.2.0, < 2.2.5>= 2.3.0, < 2.3.3
- Fixed in
- 2.1.12, 2.3.3, 2.0.24, 2.2.5
Packagist symfony/validator
- Affected
- >= 2.0.0, < 2.0.24>= 2.1.0, < 2.1.12>= 2.2.0, < 2.2.5>= 2.3.0, < 2.3.3
- Fixed in
- 2.1.12, 2.3.3, 2.0.24, 2.2.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q8j7-fjh7-25v5 lists affected ranges: Packagist symfony/validator >=2.0.0 =2.1.0 =2.2.0 =2.3.0 =2.0.0 =2.1.0 =2.2.0 =2.3.0 <2.3.3
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 8.1 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:N
- EPSS
- CVE-2013-4751: 1.44% estimated exploitation activity in the next 30 days; percentile 73.32 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
When using the Validator component, if Symfony\\Component\\Validator\\Mapping\\Cache\\ApcCache is enabled (or any other cache implementing Symfony\\Component\\Validator\\Mapping\\Cache\\CacheInterface), some information is lost during serialization (the collectionCascaded and the collectionCascadedDeeply fields). As a consequence, arrays or traversable objects stored in fields using the @Valid constraint are not traversed by the validator as soon as the validator configuration is loaded from the cache.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q8j7-fjh7-25v5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2013-4751 Advisory: Symfony collectionCascaded and collectionCascadedDeeply fields security bypass IDs: CVE-2013-4751, GHSA-q8j7-fjh7-25v5 Record: https://patchnext.com/advisories/cve-2013-4751 (revision 1, source checked 26 Oct 2026, 14:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.1) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 2.3.3, 2.2.5, 2.1.12, 2.0.24; symfony/validator 2.3.3, 2.2.5, 2.1.12, 2.0.24. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/symfony: affected >= 2.0.0, < 2.0.24; >= 2.1.0, < 2.1.12; >= 2.2.0, < 2.2.5; >= 2.3.0, < 2.3.3; fixed in 2.1.12, 2.3.3, 2.0.24, 2.2.5 - Packagist symfony/validator: affected >= 2.0.0, < 2.0.24; >= 2.1.0, < 2.1.12; >= 2.2.0, < 2.2.5; >= 2.3.0, < 2.3.3; fixed in 2.1.12, 2.3.3, 2.0.24, 2.2.5 ## Suggested inspection (read-only) - Packagist symfony/symfony: check the installed version with your package manager. - Packagist symfony/validator: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/symfony, symfony/validator. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q8j7-fjh7-25v5 (GitHub-reviewed advisory GHSA-q8j7-fjh7-25v5 lists affected ranges: Packagist symfony/validator >=2.0.0 =2.1.0 =2.2.0 =2.3.0 =2.0.0 =2.1.0 =2.2.0 =2.3.0 <2.3.3) Commands are suggestions: review each one before running it.
Loading voting…