PHPUnit extension for TYPO3 vulnerable to Cross-site Scripting
CVE-2013-4744GHSA-c5x3-gq36-prrp
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (oliverklee/phpunit 3.5.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist oliverklee/phpunit
- Affected
- < 3.5.15
- Fixed in
- 3.5.15
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c5x3-gq36-prrp lists affected ranges: Packagist oliverklee/phpunit >=0 <3.5.15
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 1.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:P/VC:N/VI:N/VA:N/SC:L/SI:L/SA:N/E:U · score source
- EPSS
- CVE-2013-4744: 1.40% estimated exploitation activity in the next 30 days; percentile 72.42 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-site scripting (XSS) vulnerability in the PHPUnit extension before 3.5.15 for TYPO3 allows remote attackers to inject arbitrary web script or HTML via unspecified vectors.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c5x3-gq36-prrp
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2013-4744 Advisory: PHPUnit extension for TYPO3 vulnerable to Cross-site Scripting IDs: CVE-2013-4744, GHSA-c5x3-gq36-prrp Record: https://patchnext.com/advisories/cve-2013-4744 (revision 1, source checked 26 Oct 2026, 14:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Low (CVSS 1.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: oliverklee/phpunit 3.5.15. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist oliverklee/phpunit: affected < 3.5.15; fixed in 3.5.15 ## Suggested inspection (read-only) - Packagist oliverklee/phpunit: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on oliverklee/phpunit. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c5x3-gq36-prrp (GitHub-reviewed advisory GHSA-c5x3-gq36-prrp lists affected ranges: Packagist oliverklee/phpunit >=0 <3.5.15) Commands are suggestions: review each one before running it.
Loading voting…