Skip to content

← Actionable
Medium, CVSS 6.9

Moodle vulnerable to Exposure of Sensitive Information to an Unauthorized Actor

CVE-2013-4522GHSA-vm9c-39jx-q45w

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 2.5.3, 2.4.7, 2.3.10), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    < 2.3.10>= 2.4.0-beta, < 2.4.7>= 2.5.0-beta, < 2.5.3
    Fixed in
    2.5.3, 2.3.10, 2.4.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:L/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2013-4522: 1.54% estimated exploitation activity in the next 30 days; percentile 74.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

lib/filelib.php in Moodle through 2.2.11, 2.3.x before 2.3.10, 2.4.x before 2.4.7, and 2.5.x before 2.5.3 does not send "Cache-Control: private" HTTP headers, which allows remote attackers to obtain sensitive information by requesting a file that had been previously retrieved by a caching proxy server.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-vm9c-39jx-q45w

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2013-4522

Advisory: Moodle vulnerable to Exposure of Sensitive Information to an Unauthorized Actor
IDs: CVE-2013-4522, GHSA-vm9c-39jx-q45w
Record: https://patchnext.com/advisories/cve-2013-4522 (revision 1, source checked 26 Oct 2026, 14:33 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 2.5.3, 2.4.7, 2.3.10. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected < 2.3.10; >= 2.4.0-beta, < 2.4.7; >= 2.5.0-beta, < 2.5.3; fixed in 2.5.3, 2.3.10, 2.4.7

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-vm9c-39jx-q45w (GitHub-reviewed advisory GHSA-vm9c-39jx-q45w lists affected ranges: Packagist moodle/moodle >=0 =2.4.0-beta =2.5.0-beta <2.5.3)

Commands are suggestions: review each one before running it.

Loading voting…