RubyGems Regular Expression Denial of Service
CVE-2013-4363GHSA-9qvm-2vhf-q649
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rubygems-update 2.1.5, 2.0.10, 1.8.27, 1.8.23.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rubygems-update
- Affected
- < 1.8.23.2>= 1.8.24, < 1.8.27>= 2.0.0, < 2.0.10>= 2.1.0, < 2.1.5
- Fixed in
- 2.0.10, 1.8.27, 2.1.5, 1.8.23.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9qvm-2vhf-q649 lists affected ranges: RubyGems rubygems-update >=0 =1.8.24 =2.0.0 =2.1.0 <2.1.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2013-4363: 1.69% estimated exploitation activity in the next 30 days; percentile 77.10 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Algorithmic complexity vulnerability in Gem::Version::ANCHOREDVERSIONPATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.2, 1.8.24 through 1.8.26, 2.0.x before 2.0.10, and 2.1.x before 2.1.5, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression. NOTE: this issue is due to an incomplete fix for CVE-2013-4287.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9qvm-2vhf-q649
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2013-4363 Advisory: RubyGems Regular Expression Denial of Service IDs: CVE-2013-4363, GHSA-9qvm-2vhf-q649 Record: https://patchnext.com/advisories/cve-2013-4363 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rubygems-update 2.1.5, 2.0.10, 1.8.27, 1.8.23.2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rubygems-update: affected < 1.8.23.2; >= 1.8.24, < 1.8.27; >= 2.0.0, < 2.0.10; >= 2.1.0, < 2.1.5; fixed in 2.0.10, 1.8.27, 2.1.5, 1.8.23.2 ## Suggested inspection (read-only) - RubyGems rubygems-update: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rubygems-update. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9qvm-2vhf-q649 (GitHub-reviewed advisory GHSA-9qvm-2vhf-q649 lists affected ranges: RubyGems rubygems-update >=0 =1.8.24 =2.0.0 =2.1.0 <2.1.5) Commands are suggestions: review each one before running it.
Loading voting…