Skip to content

← Actionable
Unrated

Improper Control of Generation of Code in Apache Camel

CVE-2013-4330GHSA-x9fv-c87w-55wc

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.camel:camel-core 2.12.1, 2.11.2, 2.10.7, 2.9.7), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.camel:camel-core

    Affected
    < 2.9.7>= 2.10.0, < 2.10.7>= 2.11.0, < 2.11.2>= 2.12.0, <= 2.12.0
    Fixed in
    2.9.7, 2.11.2, 2.12.1, 2.10.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2013-4330: 8.49% estimated exploitation activity in the next 30 days; percentile 95.04 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache Camel before 2.9.7, 2.10.0 before 2.10.7, 2.11.0 before 2.11.2, and 2.12.0 allows remote attackers to execute arbitrary simple language expressions by including "$simple{}" in a CamelFileName message header to a (1) FILE or (2) FTP producer.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x9fv-c87w-55wc

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2013-4330

Advisory: Improper Control of Generation of Code in Apache Camel
IDs: CVE-2013-4330, GHSA-x9fv-c87w-55wc
Record: https://patchnext.com/advisories/cve-2013-4330 (revision 1, source checked 26 Oct 2026, 16:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.camel:camel-core 2.12.1, 2.11.2, 2.10.7, 2.9.7. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.camel:camel-core: affected < 2.9.7; >= 2.10.0, < 2.10.7; >= 2.11.0, < 2.11.2; >= 2.12.0, <= 2.12.0; fixed in 2.9.7, 2.11.2, 2.12.1, 2.10.7

## Suggested inspection (read-only)
- Maven org.apache.camel:camel-core: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.camel:camel-core.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x9fv-c87w-55wc (GitHub-reviewed advisory GHSA-x9fv-c87w-55wc lists affected ranges: Maven org.apache.camel:camel-core >=0 =2.10.0 =2.11.0 =2.12.0 <=2.12.0)

Commands are suggestions: review each one before running it.

Loading voting…