Skip to content

← Actionable
Unrated

Apache Tomcat Denial of Service vulnerability

CVE-2013-4322GHSA-wq2p-q66w-q8gp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat 8.0.0-RC10, 7.0.50, 6.0.39), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.tomcat:tomcat

    Affected
    < 6.0.39>= 8.0.0-RC1, < 8.0.0-RC10>= 7.0.0, < 7.0.50
    Fixed in
    8.0.0-RC10, 6.0.39, 7.0.50

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2013-4322: 9.10% estimated exploitation activity in the next 30 days; percentile 95.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Apache Tomcat before 6.0.39, 7.x before 7.0.50, and 8.x before 8.0.0-RC10 processes chunked transfer coding without properly handling (1) a large total amount of chunked data or (2) whitespace characters in an HTTP header value within a trailer field, which allows remote attackers to cause a denial of service by streaming data. NOTE: this vulnerability exists because of an incomplete fix for CVE-2012-3544.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-wq2p-q66w-q8gp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2013-4322

Advisory: Apache Tomcat Denial of Service vulnerability
IDs: CVE-2013-4322, GHSA-wq2p-q66w-q8gp
Record: https://patchnext.com/advisories/cve-2013-4322 (revision 1, source checked 26 Oct 2026, 16:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat 8.0.0-RC10, 7.0.50, 6.0.39. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat: affected < 6.0.39; >= 8.0.0-RC1, < 8.0.0-RC10; >= 7.0.0, < 7.0.50; fixed in 8.0.0-RC10, 6.0.39, 7.0.50

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-wq2p-q66w-q8gp (GitHub-reviewed advisory GHSA-wq2p-q66w-q8gp lists affected ranges: Maven org.apache.tomcat:tomcat >=0 =8.0.0-RC1 =7.0.0 <7.0.50)

Commands are suggestions: review each one before running it.

Loading voting…