Skip to content

← Actionable
Unrated

RubyGems Regular Expression Denial of Service vulnerability

CVE-2013-4287GHSA-9j7m-rjqx-48vh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (rubygems-update 2.1.0, 2.0.8, 1.8.26, 1.8.23.1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems rubygems-update

    Affected
    < 1.8.23.1>= 1.8.24, < 1.8.26>= 2.0.0, < 2.0.8>= 2.1.0.rc.1, < 2.1.0
    Fixed in
    1.8.26, 1.8.23.1, 2.0.8, 2.1.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2013-4287: 3.33% estimated exploitation activity in the next 30 days; percentile 88.64 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Algorithmic complexity vulnerability in Gem::Version::VERSIONPATTERN in lib/rubygems/version.rb in RubyGems before 1.8.23.1, 1.8.24 through 1.8.25, 2.0.x before 2.0.8, and 2.1.x before 2.1.0, as used in Ruby 1.9.0 through 2.0.0p247, allows remote attackers to cause a denial of service (CPU consumption) via a crafted gem version that triggers a large amount of backtracking in a regular expression.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-9j7m-rjqx-48vh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2013-4287

Advisory: RubyGems Regular Expression Denial of Service vulnerability
IDs: CVE-2013-4287, GHSA-9j7m-rjqx-48vh
Record: https://patchnext.com/advisories/cve-2013-4287 (revision 1, source checked 26 Oct 2026, 15:47 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: rubygems-update 2.1.0, 2.0.8, 1.8.26, 1.8.23.1. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems rubygems-update: affected < 1.8.23.1; >= 1.8.24, < 1.8.26; >= 2.0.0, < 2.0.8; >= 2.1.0.rc.1, < 2.1.0; fixed in 1.8.26, 1.8.23.1, 2.0.8, 2.1.0

## Suggested inspection (read-only)
- RubyGems rubygems-update: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rubygems-update.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-9j7m-rjqx-48vh (GitHub-reviewed advisory GHSA-9j7m-rjqx-48vh lists affected ranges: RubyGems rubygems-update >=0 =1.8.24 =2.0.0 =2.1.0.rc.1 <2.1.0)

Commands are suggestions: review each one before running it.

Loading voting…