Piwik (now Matomo) Reveals Sensitive Information by Accepting Input from POST Requests
CVE-2013-2633GHSA-v8h8-93mx-82h5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (matomo/matomo 1.11; piwik/piwik 1.11), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist matomo/matomo
- Affected
- < 1.11
- Fixed in
- 1.11
Packagist piwik/piwik
- Affected
- < 1.11
- Fixed in
- 1.11
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-v8h8-93mx-82h5 lists affected ranges: Packagist matomo/matomo >=0 =0 <1.11
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2013-2633: 0.99% estimated exploitation activity in the next 30 days; percentile 62.66 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Piwik before 1.11 accepts input from a POST request instead of a GET request in unspecified circumstances, which might allow attackers to obtain sensitive information by leveraging the logging of parameters.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-v8h8-93mx-82h5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2013-2633 Advisory: Piwik (now Matomo) Reveals Sensitive Information by Accepting Input from `POST` Requests IDs: CVE-2013-2633, GHSA-v8h8-93mx-82h5 Record: https://patchnext.com/advisories/cve-2013-2633 (revision 1, source checked 26 Oct 2026, 14:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.6) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: matomo/matomo 1.11; piwik/piwik 1.11. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist matomo/matomo: affected < 1.11; fixed in 1.11 - Packagist piwik/piwik: affected < 1.11; fixed in 1.11 ## Suggested inspection (read-only) - Packagist matomo/matomo: check the installed version with your package manager. - Packagist piwik/piwik: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on matomo/matomo, piwik/piwik. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-v8h8-93mx-82h5 (GitHub-reviewed advisory GHSA-v8h8-93mx-82h5 lists affected ranges: Packagist matomo/matomo >=0 =0 <1.11) Commands are suggestions: review each one before running it.
Loading voting…