spree_auth_devise allows remote authenticated users to assign themselves arbitrary roles
CVE-2013-2506GHSA-jp57-9j37-5476
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (spree_auth_devise 3.0.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems spree_auth_devise
- Affected
- >= 1.0.0, < 3.0.5
- Fixed in
- 3.0.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-jp57-9j37-5476 lists affected ranges: RubyGems spree_auth_devise >=1.0.0 <3.0.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2013-2506: 1.26% estimated exploitation activity in the next 30 days; percentile 69.75 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
app/models/spree/user.rb in spreeauthdevise in Spree 1.1.x before 1.1.6, 1.2.x, and 1.3.x does not perform mass assignment safely when updating a user, which allows remote authenticated users to assign arbitrary roles to themselves.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-jp57-9j37-5476
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2013-2506 Advisory: spree_auth_devise allows remote authenticated users to assign themselves arbitrary roles IDs: CVE-2013-2506, GHSA-jp57-9j37-5476 Record: https://patchnext.com/advisories/cve-2013-2506 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: spree_auth_devise 3.0.5. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems spree_auth_devise: affected >= 1.0.0, < 3.0.5; fixed in 3.0.5 ## Suggested inspection (read-only) - RubyGems spree_auth_devise: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on spree_auth_devise. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-jp57-9j37-5476 (GitHub-reviewed advisory GHSA-jp57-9j37-5476 lists affected ranges: RubyGems spree_auth_devise >=1.0.0 <3.0.5) Commands are suggestions: review each one before running it.
Loading voting…