Skip to content

← Actionable
Medium, CVSS 6.9amended

Improper Link Resolution Before File Access in Suds

CVE-2013-2217GHSA-vpqp-hx68-p2wx

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (suds-py3 1.4.4.1; suds 1.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI suds-py3

    Affected
    < 1.4.4.1
    Fixed in
    1.4.4.1
  • PyPI suds

    Affected
    <= 0.4
    Fixed in
    1.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.9 · CVSS:4.0/AV:L/AC:L/AT:N/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2013-2217: 0.56% estimated exploitation activity in the next 30 days; percentile 46.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

cache.py in Suds 0.4, when tempdir is set to None, allows local users to redirect SOAP queries and possibly have other unspecified impact via a symlink attack on a cache file with a predictable name in /tmp/suds/.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-vpqp-hx68-p2wx

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-vpqp-hx68-p2wx

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2013-2217

Advisory: Improper Link Resolution Before File Access in Suds
IDs: CVE-2013-2217, GHSA-vpqp-hx68-p2wx
Record: https://patchnext.com/advisories/cve-2013-2217 (revision 3, source checked 26 Oct 2026, 13:25 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.9)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: suds-py3 1.4.4.1; suds 1.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI suds-py3: affected < 1.4.4.1; fixed in 1.4.4.1
- PyPI suds: affected <= 0.4; fixed in 1.0.0

## Suggested inspection (read-only)
- `python -m pip show suds-py3`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show suds`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on suds-py3, suds.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-vpqp-hx68-p2wx (OSV record GHSA-vpqp-hx68-p2wx lists affected ranges: PyPI suds >=0 =0 <1.4.4.1 (fixed))
- Verified: https://github.com/advisories/GHSA-vpqp-hx68-p2wx (GitHub-reviewed advisory GHSA-vpqp-hx68-p2wx lists affected ranges: PyPI suds >=0 =0 <1.4.4.1)

Commands are suggestions: review each one before running it.

Loading voting…