Improper Authentication in Apache Hadoop
CVE-2013-2192GHSA-pxv5-5vmp-3jj4
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.hadoop:hadoop-common 2.0.6-alpha, 0.23.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.hadoop:hadoop-common
- Affected
- >= 2.0.0, <= 2.0.5-alpha>= 0.23.0, < 0.23.9
- Fixed in
- 2.0.6-alpha, 0.23.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-pxv5-5vmp-3jj4 lists affected ranges: Maven org.apache.hadoop:hadoop-common >=2.0.0 =0.23.0 <0.23.9
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2013-2192: 1.07% estimated exploitation activity in the next 30 days; percentile 64.86 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The RPC protocol implementation in Apache Hadoop 2.x before 2.0.6-alpha, 0.23.x before 0.23.9, and 1.x before 1.2.1, when the Kerberos security features are enabled, allows man-in-the-middle attackers to disable bidirectional authentication and obtain sensitive information by forcing a downgrade to simple authentication.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-pxv5-5vmp-3jj4
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2013-2192 Advisory: Improper Authentication in Apache Hadoop IDs: CVE-2013-2192, GHSA-pxv5-5vmp-3jj4 Record: https://patchnext.com/advisories/cve-2013-2192 (revision 1, source checked 26 Oct 2026, 16:01 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.hadoop:hadoop-common 2.0.6-alpha, 0.23.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.hadoop:hadoop-common: affected >= 2.0.0, <= 2.0.5-alpha; >= 0.23.0, < 0.23.9; fixed in 2.0.6-alpha, 0.23.9 ## Suggested inspection (read-only) - Maven org.apache.hadoop:hadoop-common: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.hadoop:hadoop-common. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-pxv5-5vmp-3jj4 (GitHub-reviewed advisory GHSA-pxv5-5vmp-3jj4 lists affected ranges: Maven org.apache.hadoop:hadoop-common >=2.0.0 =0.23.0 <0.23.9) Commands are suggestions: review each one before running it.
Loading voting…