Skip to content

← Actionable
Unratedamended

jplayer Cross Site Scripting vulnerability

CVE-2013-2022GHSA-3jcq-cwr7-6332

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (jplayer 2.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • npm jplayer

    Affected
    < 2.3.0
    Fixed in
    2.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2013-2022: 2.73% estimated exploitation activity in the next 30 days; percentile 86.13 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Multiple cross-site scripting (XSS) vulnerabilities in actionscript/Jplayer.as in the Flash SWF component (jplayer.swf) in jPlayer before 2.3.0 allow remote attackers to inject arbitrary web script or HTML via the (1) jQuery or (2) id parameters, a different vulnerability than CVE-2013-1942 and CVE-2013-2023, as demonstrated by using the alert function in the jQuery parameter. NOTE: these are the same parameters as CVE-2013-1942, but the fix for CVE-2013-1942 uses a blacklist for the jQuery parameter.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 2 · amended ·

    Amended from ghsa record GHSA-3jcq-cwr7-6332

  2. Revision 1 · created ·

    Published from osv record GHSA-3jcq-cwr7-6332

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2013-2022

Advisory: jplayer Cross Site Scripting vulnerability
IDs: CVE-2013-2022, GHSA-3jcq-cwr7-6332
Record: https://patchnext.com/advisories/cve-2013-2022 (revision 2, source checked 26 Oct 2026, 12:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: jplayer 2.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- npm jplayer: affected < 2.3.0; fixed in 2.3.0

## Suggested inspection (read-only)
- `npm ls jplayer --all`: lists every installed copy and version, including transitive ones. Run in the project root after `npm ci`.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on jplayer.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-3jcq-cwr7-6332 (OSV record GHSA-3jcq-cwr7-6332 lists affected ranges: npm jplayer >=0 <2.3.0 (fixed))
- Verified: https://github.com/advisories/GHSA-3jcq-cwr7-6332 (GitHub-reviewed advisory GHSA-3jcq-cwr7-6332 lists affected ranges: npm jplayer >=0 <2.3.0)

Commands are suggestions: review each one before running it.

Loading voting…