Skip to content

← Actionable
Unrated

Moodle allows remote authenticated users to reassign notes

CVE-2013-1834GHSA-prrh-679x-79qh

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 2.4.2, 2.3.5, 2.2.8), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 1.9.0, < 2.2.8>= 2.3.0, < 2.3.5>= 2.4.0, < 2.4.2
    Fixed in
    2.2.8, 2.4.2, 2.3.5

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2013-1834: 1.66% estimated exploitation activity in the next 30 days; percentile 76.74 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

notes/edit.php in Moodle 1.9.x through 1.9.19, 2.x through 2.1.10, 2.2.x before 2.2.8, 2.3.x before 2.3.5, and 2.4.x before 2.4.2 allows remote authenticated users to reassign notes via a modified (1) userid or (2) courseid field.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-prrh-679x-79qh

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2013-1834

Advisory: Moodle allows remote authenticated users to reassign notes
IDs: CVE-2013-1834, GHSA-prrh-679x-79qh
Record: https://patchnext.com/advisories/cve-2013-1834 (revision 1, source checked 26 Oct 2026, 14:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 2.4.2, 2.3.5, 2.2.8. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 1.9.0, < 2.2.8; >= 2.3.0, < 2.3.5; >= 2.4.0, < 2.4.2; fixed in 2.2.8, 2.4.2, 2.3.5

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-prrh-679x-79qh (GitHub-reviewed advisory GHSA-prrh-679x-79qh lists affected ranges: Packagist moodle/moodle >=1.9.0 =2.3.0 =2.4.0 <2.4.2)

Commands are suggestions: review each one before running it.

Loading voting…