PyCrypto does not properly reseed PRNG before allowing access
CVE-2013-1445GHSA-x377-f64p-hf5j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (pycrypto 2.6.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI pycrypto
- Affected
- < 2.6.1
- Fixed in
- 2.6.1
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-x377-f64p-hf5j lists affected ranges: PyPI pycrypto >=0 <2.6.1 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x377-f64p-hf5j lists affected ranges: PyPI pycrypto >=0 <2.6.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
- EPSS
- CVE-2013-1445: 1.75% estimated exploitation activity in the next 30 days; percentile 77.82 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Crypto.Random.atfork function in PyCrypto before 2.6.1 does not properly reseed the pseudo-random number generator (PRNG) before allowing a child process to access it, which makes it easier for context-dependent attackers to obtain sensitive information by leveraging a race condition in which a child process is created and accesses the PRNG within the same rate-limit period as another process.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 3 · amended ·
Amended from ghsa record GHSA-x377-f64p-hf5j
- Revision 2 · amended ·
Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.
- Revision 1 · created ·
Published from osv record GHSA-x377-f64p-hf5j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2013-1445 Advisory: PyCrypto does not properly reseed PRNG before allowing access IDs: CVE-2013-1445, GHSA-x377-f64p-hf5j Record: https://patchnext.com/advisories/cve-2013-1445 (revision 3, source checked 26 Oct 2026, 13:22 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: High (CVSS 8.7) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: pycrypto 2.6.1. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI pycrypto: affected < 2.6.1; fixed in 2.6.1 ## Suggested inspection (read-only) - `python -m pip show pycrypto`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on pycrypto. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-x377-f64p-hf5j (OSV record GHSA-x377-f64p-hf5j lists affected ranges: PyPI pycrypto >=0 <2.6.1 (fixed)) - Verified: https://github.com/advisories/GHSA-x377-f64p-hf5j (GitHub-reviewed advisory GHSA-x377-f64p-hf5j lists affected ranges: PyPI pycrypto >=0 <2.6.1) Commands are suggestions: review each one before running it.
Loading voting…