Symphony Vulnerable to PHP Code Injection via YAML Parsing
CVE-2013-1348GHSA-2r5h-6r7v-5m7c
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 2.0.22; symfony/yaml 2.0.22), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/symfony
- Affected
- >= 2.0.0, < 2.0.22
- Fixed in
- 2.0.22
Packagist symfony/yaml
- Affected
- >= 2.0.0, < 2.0.22
- Fixed in
- 2.0.22
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2r5h-6r7v-5m7c lists affected ranges: Packagist symfony/symfony >=2.0.0 =2.0.0 <2.0.22
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2013-1348: 1.62% estimated exploitation activity in the next 30 days; percentile 76.09 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Yaml::parse function in Symfony 2.0.x before 2.0.22 remote attackers to execute arbitrary PHP code via a PHP file, a different vulnerability than CVE-2013-1397.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2r5h-6r7v-5m7c
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2013-1348 Advisory: Symphony Vulnerable to PHP Code Injection via YAML Parsing IDs: CVE-2013-1348, GHSA-2r5h-6r7v-5m7c Record: https://patchnext.com/advisories/cve-2013-1348 (revision 1, source checked 26 Oct 2026, 14:20 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 2.0.22; symfony/yaml 2.0.22. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/symfony: affected >= 2.0.0, < 2.0.22; fixed in 2.0.22 - Packagist symfony/yaml: affected >= 2.0.0, < 2.0.22; fixed in 2.0.22 ## Suggested inspection (read-only) - Packagist symfony/symfony: check the installed version with your package manager. - Packagist symfony/yaml: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/symfony, symfony/yaml. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2r5h-6r7v-5m7c (GitHub-reviewed advisory GHSA-2r5h-6r7v-5m7c lists affected ranges: Packagist symfony/symfony >=2.0.0 =2.0.0 <2.0.22) Commands are suggestions: review each one before running it.
Loading voting…