JSON gem has Improper Input Validation vulnerability
CVE-2013-0269GHSA-x457-cw4h-hq5f
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (json 1.7.7, 1.6.8, 1.5.5), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems json
- Affected
- < 1.5.5>= 1.6.0, < 1.6.8>= 1.7.0, < 1.7.7
- Fixed in
- 1.6.8, 1.7.7, 1.5.5
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-x457-cw4h-hq5f lists affected ranges: RubyGems json >=0 =1.6.0 =1.7.0 <1.7.7
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2013-0269: 13.91% estimated exploitation activity in the next 30 days; percentile 96.54 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The JSON gem before 1.5.5, 1.6.x before 1.6.8, and 1.7.x before 1.7.7 for Ruby allows remote attackers to cause a denial of service (resource consumption) or bypass the mass assignment protection mechanism via a crafted JSON document that triggers the creation of arbitrary Ruby symbols or certain internal objects, as demonstrated by conducting a SQL injection attack against Ruby on Rails, aka "Unsafe Object Creation Vulnerability."
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-x457-cw4h-hq5f
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2013-0269 Advisory: JSON gem has Improper Input Validation vulnerability IDs: CVE-2013-0269, GHSA-x457-cw4h-hq5f Record: https://patchnext.com/advisories/cve-2013-0269 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: json 1.7.7, 1.6.8, 1.5.5. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems json: affected < 1.5.5; >= 1.6.0, < 1.6.8; >= 1.7.0, < 1.7.7; fixed in 1.6.8, 1.7.7, 1.5.5 ## Suggested inspection (read-only) - RubyGems json: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on json. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-x457-cw4h-hq5f (GitHub-reviewed advisory GHSA-x457-cw4h-hq5f lists affected ranges: RubyGems json >=0 =1.6.0 =1.7.0 <1.7.7) Commands are suggestions: review each one before running it.
Loading voting…