ruby_parser allows local users to overwrite arbitrary files via symlink attack on temporary file with predictable name
CVE-2013-0162GHSA-8mvw-22r7-w6fq
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (ruby_parser 3.1.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems ruby_parser
- Affected
- >= 2.0.2, < 3.1.2
- Fixed in
- 3.1.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8mvw-22r7-w6fq lists affected ranges: RubyGems ruby_parser >=2.0.2 <3.1.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2013-0162: 0.37% estimated exploitation activity in the next 30 days; percentile 31.12 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The diffpp function in lib/gauntletrubyparser.rb in the rubyparser gem 3.1.1 and earlier for Ruby allows local users to overwrite arbitrary files via a symlink attack on a temporary file with a predictable name in /tmp.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8mvw-22r7-w6fq
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2013-0162 Advisory: ruby_parser allows local users to overwrite arbitrary files via symlink attack on temporary file with predictable name IDs: CVE-2013-0162, GHSA-8mvw-22r7-w6fq Record: https://patchnext.com/advisories/cve-2013-0162 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: ruby_parser 3.1.2. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems ruby_parser: affected >= 2.0.2, < 3.1.2; fixed in 3.1.2 ## Suggested inspection (read-only) - RubyGems ruby_parser: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on ruby_parser. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8mvw-22r7-w6fq (GitHub-reviewed advisory GHSA-8mvw-22r7-w6fq lists affected ranges: RubyGems ruby_parser >=2.0.2 <3.1.2) Commands are suggestions: review each one before running it.
Loading voting…