RedCloth Cross-site Scripting vulnerability
CVE-2012-6684GHSA-r23g-3qw4-gfh2
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (redcloth 4.3.0), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems redcloth
- Affected
- < 4.3.0
- Fixed in
- 4.3.0
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-r23g-3qw4-gfh2 lists affected ranges: RubyGems redcloth >=0 <4.3.0
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2012-6684: 2.25% estimated exploitation activity in the next 30 days; percentile 82.94 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Cross-site scripting (XSS) vulnerability in the RedCloth library 4.2.9 for Ruby and earlier allows remote attackers to inject arbitrary web script or HTML via a javascript: URI.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-r23g-3qw4-gfh2
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2012-6684 Advisory: RedCloth Cross-site Scripting vulnerability IDs: CVE-2012-6684, GHSA-r23g-3qw4-gfh2 Record: https://patchnext.com/advisories/cve-2012-6684 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: redcloth 4.3.0. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems redcloth: affected < 4.3.0; fixed in 4.3.0 ## Suggested inspection (read-only) - RubyGems redcloth: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on redcloth. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-r23g-3qw4-gfh2 (GitHub-reviewed advisory GHSA-r23g-3qw4-gfh2 lists affected ranges: RubyGems redcloth >=0 <4.3.0) Commands are suggestions: review each one before running it.
Loading voting…