Skip to content

← Actionable
High, CVSS 8.7amended

Plone and Zope2 do not reseed pseudo-random number generator

CVE-2012-6661GHSA-48vv-2pmq-9fvv

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (zope2 2.13.19; plone 4.2.3, 4.3b1), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI zope2

    Affected
    < 2.13.19
    Fixed in
    2.13.19
  • PyPI plone

    Affected
    >= 3.2.2, < 4.2.3>= 4.3a1, <= 4.3a2
    Fixed in
    4.3b1, 4.2.3

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2012-6661: 2.38% estimated exploitation activity in the next 30 days; percentile 83.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Zope before 2.13.19, as used in Plone before 4.2.3 and 4.3 before beta 1, does not reseed the pseudo-random number generator (PRNG), which makes it easier for remote attackers to guess the value via unspecified vectors. NOTE: this issue was SPLIT from CVE-2012-5508 due to different vulnerability types (ADT2).

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-48vv-2pmq-9fvv

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-48vv-2pmq-9fvv

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2012-6661

Advisory: Plone and Zope2 do not reseed pseudo-random number generator
IDs: CVE-2012-6661, GHSA-48vv-2pmq-9fvv
Record: https://patchnext.com/advisories/cve-2012-6661 (revision 3, source checked 26 Oct 2026, 13:21 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: zope2 2.13.19; plone 4.2.3, 4.3b1. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI zope2: affected < 2.13.19; fixed in 2.13.19
- PyPI plone: affected >= 3.2.2, < 4.2.3; >= 4.3a1, <= 4.3a2; fixed in 4.3b1, 4.2.3

## Suggested inspection (read-only)
- `python -m pip show zope2`: prints the installed version. Run with the environment that serves production active.
- `python -m pip show plone`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on zope2, plone.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-48vv-2pmq-9fvv (OSV record GHSA-48vv-2pmq-9fvv lists affected ranges: PyPI zope2 >=0 =3.2.2 =4.3a1 <4.3b1 (fixed))
- Verified: https://github.com/advisories/GHSA-48vv-2pmq-9fvv (GitHub-reviewed advisory GHSA-48vv-2pmq-9fvv lists affected ranges: PyPI zope2 >=0 =3.2.2 =4.3a1 <=4.3a2)

Commands are suggestions: review each one before running it.

Loading voting…