Skip to content

← Actionable
Unrated

Authlogic Information Exposure vulnerability

CVE-2012-6497GHSA-rx7j-mw4c-76g9

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (authlogic 3.3.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems authlogic

    Affected
    < 3.3.0
    Fixed in
    3.3.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2012-6497: 2.74% estimated exploitation activity in the next 30 days; percentile 86.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The Authlogic gem for Ruby on Rails prior to version 3.3.0 makes potentially unsafe findbyid method calls, which might allow remote attackers to conduct CVE-2012-6496 SQL injection attacks via a crafted parameter in environments that have a known secrettoken value, as demonstrated by a value contained in secrettoken.rb in an open-source product.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-rx7j-mw4c-76g9

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2012-6497

Advisory: Authlogic Information Exposure vulnerability
IDs: CVE-2012-6497, GHSA-rx7j-mw4c-76g9
Record: https://patchnext.com/advisories/cve-2012-6497 (revision 1, source checked 26 Oct 2026, 15:43 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: authlogic 3.3.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems authlogic: affected < 3.3.0; fixed in 3.3.0

## Suggested inspection (read-only)
- RubyGems authlogic: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on authlogic.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-rx7j-mw4c-76g9 (GitHub-reviewed advisory GHSA-rx7j-mw4c-76g9 lists affected ranges: RubyGems authlogic >=0 <3.3.0)

Commands are suggestions: review each one before running it.

Loading voting…