Symfony Access Control Vulnerability
CVE-2012-6432GHSA-89cp-fvcc-hxh7
What to do
Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/symfony
- Affected
- >= 2.2-dev, <= 2.2-dev>= 2.0.0, < 2.0.20>= 2.1.0, < 2.1.5
- Fixed in
- 2.1.5, 2.0.20
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-89cp-fvcc-hxh7 lists affected ranges: Packagist symfony/symfony >=2.2-dev =2.0.0 =2.1.0 <2.1.5
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2012-6432: 1.17% estimated exploitation activity in the next 30 days; percentile 67.51 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Symfony 2.0.x before 2.0.20, 2.1.x before 2.1.5, and 2.2-dev, when the internal routes configuration is enabled, allows remote attackers to access arbitrary services via vectors involving a URI beginning with a /internal substring.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-89cp-fvcc-hxh7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2012-6432 Advisory: Symfony Access Control Vulnerability IDs: CVE-2012-6432, GHSA-89cp-fvcc-hxh7 Record: https://patchnext.com/advisories/cve-2012-6432 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Partial vendor fix; fixed versions by package: symfony/symfony 2.1.5, 2.0.20. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/symfony: affected >= 2.2-dev, <= 2.2-dev; >= 2.0.0, < 2.0.20; >= 2.1.0, < 2.1.5; fixed in 2.1.5, 2.0.20 ## Suggested inspection (read-only) - Packagist symfony/symfony: check the installed version with your package manager. ## Supported action No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/symfony. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-89cp-fvcc-hxh7 (GitHub-reviewed advisory GHSA-89cp-fvcc-hxh7 lists affected ranges: Packagist symfony/symfony >=2.2-dev =2.0.0 =2.1.0 <2.1.5) Commands are suggestions: review each one before running it.
Loading voting…