Symfony Allows URI Restrictions Bypass Via Double-Encoded String
CVE-2012-6431GHSA-83c3-qx27-2rwr
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (symfony/symfony 2.0.19; symfony/routing 2.0.19; symfony/security 2.0.19; symfony/http-foundation 2.0.19), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist symfony/symfony
- Affected
- >= 2.0.0, < 2.0.19
- Fixed in
- 2.0.19
Packagist symfony/routing
- Affected
- >= 2.0.0, < 2.0.19
- Fixed in
- 2.0.19
Packagist symfony/security
- Affected
- >= 2.0.0, < 2.0.19
- Fixed in
- 2.0.19
Packagist symfony/http-foundation
- Affected
- >= 2.0.0, < 2.0.19
- Fixed in
- 2.0.19
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-83c3-qx27-2rwr lists affected ranges: Packagist symfony/http-foundation >=2.0.0 =2.0.0 =2.0.0 =2.0.0 <2.0.19
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2012-6431: 1.88% estimated exploitation activity in the next 30 days; percentile 79.44 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
On the Symfony 2.0.x version, there's a security issue that allows access to routes protected by a firewall even when the user is not logged in. Both the Routing component and the Security component uses the path returned by getPathInfo() to match a Request. The getPathInfo() returns a decoded path, but the Routing component (Symfony\Component\Routing\Matcher\UrlMatcher) decodes the path a second time; whereas the Security component, Symfony\Component\HttpFoundation\RequestMatcher, does not. This difference causes Symfony 2.0 to be vulnerable to double encoding attacks.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-83c3-qx27-2rwr
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2012-6431 Advisory: Symfony Allows URI Restrictions Bypass Via Double-Encoded String IDs: CVE-2012-6431, GHSA-83c3-qx27-2rwr Record: https://patchnext.com/advisories/cve-2012-6431 (revision 1, source checked 26 Oct 2026, 14:15 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: symfony/symfony 2.0.19; symfony/routing 2.0.19; symfony/security 2.0.19; symfony/http-foundation 2.0.19. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist symfony/symfony: affected >= 2.0.0, < 2.0.19; fixed in 2.0.19 - Packagist symfony/routing: affected >= 2.0.0, < 2.0.19; fixed in 2.0.19 - Packagist symfony/security: affected >= 2.0.0, < 2.0.19; fixed in 2.0.19 - Packagist symfony/http-foundation: affected >= 2.0.0, < 2.0.19; fixed in 2.0.19 ## Suggested inspection (read-only) - Packagist symfony/symfony: check the installed version with your package manager. - Packagist symfony/routing: check the installed version with your package manager. - Packagist symfony/security: check the installed version with your package manager. - Packagist symfony/http-foundation: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on symfony/symfony, symfony/routing, symfony/security, symfony/http-foundation. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-83c3-qx27-2rwr (GitHub-reviewed advisory GHSA-83c3-qx27-2rwr lists affected ranges: Packagist symfony/http-foundation >=2.0.0 =2.0.0 =2.0.0 =2.0.0 <2.0.19) Commands are suggestions: review each one before running it.
Loading voting…