Zend Framework XXE Vulnerability
CVE-2012-5657GHSA-9m5v-vq4f-mrvf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (zendframework/zendframework1 1.12.1, 1.11.15), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist zendframework/zendframework1
- Affected
- < 1.11.15>= 1.12.0-rc1, < 1.12.1
- Fixed in
- 1.11.15, 1.12.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-9m5v-vq4f-mrvf lists affected ranges: Packagist zendframework/zendframework1 >=0 =1.12.0-rc1 <1.12.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2012-5657: 1.70% estimated exploitation activity in the next 30 days; percentile 77.31 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The (1) ZendFeedRss and (2) ZendFeedAtom classes in ZendFeed in Zend Framework 1.11.x before 1.11.15 and 1.12.x before 1.12.1 allow remote attackers to read arbitrary files, send HTTP requests to intranet servers, and possibly cause a denial of service (CPU and memory consumption) via an XML External Entity (XXE) attack.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-9m5v-vq4f-mrvf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2012-5657 Advisory: Zend Framework XXE Vulnerability IDs: CVE-2012-5657, GHSA-9m5v-vq4f-mrvf Record: https://patchnext.com/advisories/cve-2012-5657 (revision 1, source checked 26 Oct 2026, 14:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: zendframework/zendframework1 1.12.1, 1.11.15. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist zendframework/zendframework1: affected < 1.11.15; >= 1.12.0-rc1, < 1.12.1; fixed in 1.11.15, 1.12.1 ## Suggested inspection (read-only) - Packagist zendframework/zendframework1: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on zendframework/zendframework1. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-9m5v-vq4f-mrvf (GitHub-reviewed advisory GHSA-9m5v-vq4f-mrvf lists affected ranges: Packagist zendframework/zendframework1 >=0 =1.12.0-rc1 <1.12.1) Commands are suggestions: review each one before running it.
Loading voting…