Skip to content

← Actionable
High, CVSS 8.2amended

OpenStack Keystone Insufficient token expiration

CVE-2012-5563GHSA-w66p-78g4-mr7g

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (keystone 8.0.0), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • PyPI keystone

    Affected
    < 8.0.0
    Fixed in
    8.0.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.2 · CVSS:4.0/AV:N/AC:L/AT:P/PR:N/UI:N/VC:N/VI:H/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2012-5563: 2.86% estimated exploitation activity in the next 30 days; percentile 86.78 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

OpenStack Keystone, as used in OpenStack Folsom 2012.2, does not properly implement token expiration, which allows remote authenticated users to bypass intended authorization restrictions by creating new tokens through token chaining. NOTE: this issue exists because of a CVE-2012-3426 regression.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 3 · amended ·

    Amended from ghsa record GHSA-w66p-78g4-mr7g

  2. Revision 2 · amended ·

    Reviewed OSV alias/range/CVSS4 correction; package source scopes and original publication preserved. No customer finding resolved.

  3. Revision 1 · created ·

    Published from osv record GHSA-w66p-78g4-mr7g

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2012-5563

Advisory: OpenStack Keystone Insufficient token expiration
IDs: CVE-2012-5563, GHSA-w66p-78g4-mr7g
Record: https://patchnext.com/advisories/cve-2012-5563 (revision 3, source checked 26 Oct 2026, 13:20 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.2)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: keystone 8.0.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- PyPI keystone: affected < 8.0.0; fixed in 8.0.0

## Suggested inspection (read-only)
- `python -m pip show keystone`: prints the installed version. Run with the environment that serves production active.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on keystone.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://osv.dev/vulnerability/GHSA-w66p-78g4-mr7g (OSV record GHSA-w66p-78g4-mr7g lists affected ranges: PyPI keystone >=0 <8.0.0 (fixed))
- Verified: https://github.com/advisories/GHSA-w66p-78g4-mr7g (GitHub-reviewed advisory GHSA-w66p-78g4-mr7g lists affected ranges: PyPI keystone >=0 <8.0.0)

Commands are suggestions: review each one before running it.

Loading voting…