Moodle Allows Unauthenticated Dropbox Access
CVE-2012-5471GHSA-mpjx-8phj-5m34
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 2.3.3, 2.2.6, 2.1.9), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- >= 2.3, <= 2.3.2>= 2.2, <= 2.2.5>= 2.1, <= 2.1.8
- Fixed in
- 2.3.3, 2.2.6, 2.1.9
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-mpjx-8phj-5m34 lists affected ranges: Packagist moodle/moodle >=2.3 =2.2 =2.1 <=2.1.8
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2012-5471: 1.26% estimated exploitation activity in the next 30 days; percentile 69.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Dropbox Repository File Picker in Moodle 2.1.x before 2.1.9, 2.2.x before 2.2.6, and 2.3.x before 2.3.3 allows remote authenticated users to access the Dropbox of a different user by leveraging an unattended workstation after a logout.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-mpjx-8phj-5m34
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2012-5471 Advisory: Moodle Allows Unauthenticated Dropbox Access IDs: CVE-2012-5471, GHSA-mpjx-8phj-5m34 Record: https://patchnext.com/advisories/cve-2012-5471 (revision 1, source checked 26 Oct 2026, 14:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 2.3.3, 2.2.6, 2.1.9. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected >= 2.3, <= 2.3.2; >= 2.2, <= 2.2.5; >= 2.1, <= 2.1.8; fixed in 2.3.3, 2.2.6, 2.1.9 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-mpjx-8phj-5m34 (GitHub-reviewed advisory GHSA-mpjx-8phj-5m34 lists affected ranges: Packagist moodle/moodle >=2.3 =2.2 =2.1 <=2.1.8) Commands are suggestions: review each one before running it.
Loading voting…