Use of a Broken or Risky Cryptographic Algorithm in Apache Hadoop
CVE-2012-4449GHSA-q46v-cj5v-hvg6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.hadoop:hadoop-client 2.0.2, 1.0.4, 0.23.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.hadoop:hadoop-client
- Affected
- < 0.23.4>= 1.0.0, < 1.0.4>= 2.0.0, < 2.0.2
- Fixed in
- 1.0.4, 2.0.2, 0.23.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-q46v-cj5v-hvg6 lists affected ranges: Maven org.apache.hadoop:hadoop-client >=0 =1.0.0 =2.0.0 <2.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 9.8 · CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H
- EPSS
- CVE-2012-4449: 1.19% estimated exploitation activity in the next 30 days; percentile 68.01 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Hadoop before 0.23.4, 1.x before 1.0.4, and 2.x before 2.0.2 generate token passwords using a 20-bit secret when Kerberos security features are enabled, which makes it easier for context-dependent attackers to crack secret keys via a brute-force attack.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-q46v-cj5v-hvg6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2012-4449 Advisory: Use of a Broken or Risky Cryptographic Algorithm in Apache Hadoop IDs: CVE-2012-4449, GHSA-q46v-cj5v-hvg6 Record: https://patchnext.com/advisories/cve-2012-4449 (revision 1, source checked 26 Oct 2026, 16:00 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Critical (CVSS 9.8) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.hadoop:hadoop-client 2.0.2, 1.0.4, 0.23.4. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.hadoop:hadoop-client: affected < 0.23.4; >= 1.0.0, < 1.0.4; >= 2.0.0, < 2.0.2; fixed in 1.0.4, 2.0.2, 0.23.4 ## Suggested inspection (read-only) - Maven org.apache.hadoop:hadoop-client: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.hadoop:hadoop-client. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-q46v-cj5v-hvg6 (GitHub-reviewed advisory GHSA-q46v-cj5v-hvg6 lists affected ranges: Maven org.apache.hadoop:hadoop-client >=0 =1.0.0 =2.0.0 <2.0.2) Commands are suggestions: review each one before running it.
Loading voting…