Apache Tomcat Vulnerable to Denial of Service (DoS) via Improper Handling of chunk extensions
CVE-2012-3544GHSA-qfxv-3ppc-7qg5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat 7.0.30, 6.0.37), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat
- Affected
- >= 6.0.0, < 6.0.37>= 7.0.0, < 7.0.30
- Fixed in
- 7.0.30, 6.0.37
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qfxv-3ppc-7qg5 lists affected ranges: Maven org.apache.tomcat:tomcat >=6.0.0 =7.0.0 <7.0.30
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2012-3544: 11.00% estimated exploitation activity in the next 30 days; percentile 95.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Tomcat 6.x before 6.0.37 and 7.x before 7.0.30 does not properly handle chunk extensions in chunked transfer coding, which allows remote attackers to cause a denial of service by streaming data.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qfxv-3ppc-7qg5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2012-3544 Advisory: Apache Tomcat Vulnerable to Denial of Service (DoS) via Improper Handling of chunk extensions IDs: CVE-2012-3544, GHSA-qfxv-3ppc-7qg5 Record: https://patchnext.com/advisories/cve-2012-3544 (revision 1, source checked 26 Oct 2026, 16:35 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat 7.0.30, 6.0.37. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat: affected >= 6.0.0, < 6.0.37; >= 7.0.0, < 7.0.30; fixed in 7.0.30, 6.0.37 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qfxv-3ppc-7qg5 (GitHub-reviewed advisory GHSA-qfxv-3ppc-7qg5 lists affected ranges: Maven org.apache.tomcat:tomcat >=6.0.0 =7.0.0 <7.0.30) Commands are suggestions: review each one before running it.
Loading voting…