Skip to content

← Actionable
Medium, CVSS 6.1

Apache James Hupa Webmail application Cross-site Scripting Vulnerabilities

CVE-2012-3536GHSA-7crp-p2vc-69r7

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.james.hupa:hupa-parent 0.0.3), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
6.1 · CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N
EPSS
  • CVE-2012-3536: 1.92% estimated exploitation activity in the next 30 days; percentile 79.89 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Two XSS vulnerabilities were fixed in message list and view in the Hupa Webmail application from the Apache James project. An attacker could send a carefully crafted email to a user of Hupa which would trigger a XSS when the email was opened or when a list of messages were viewed. This issue was addressed in Hupa 0.0.3.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-7crp-p2vc-69r7

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2012-3536

Advisory: Apache James Hupa Webmail application Cross-site Scripting Vulnerabilities
IDs: CVE-2012-3536, GHSA-7crp-p2vc-69r7
Record: https://patchnext.com/advisories/cve-2012-3536 (revision 1, source checked 26 Oct 2026, 16:12 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.1)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.james.hupa:hupa-parent 0.0.3. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.james.hupa:hupa-parent: affected < 0.0.3; fixed in 0.0.3

## Suggested inspection (read-only)
- Maven org.apache.james.hupa:hupa-parent: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.james.hupa:hupa-parent.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-7crp-p2vc-69r7 (GitHub-reviewed advisory GHSA-7crp-p2vc-69r7 lists affected ranges: Maven org.apache.james.hupa:hupa-parent >=0 <0.0.3)

Commands are suggestions: review each one before running it.

Loading voting…