Skip to content

← Actionable
Unrated

Typo3 API XSS Vulnerability

CVE-2012-3530GHSA-94c2-g68f-9r98

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (typo3/cms 4.7.4, 4.6.12, 4.5.19), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist typo3/cms

    Affected
    >= 4.5, < 4.5.19>= 4.6, < 4.6.12>= 4.7, < 4.7.4
    Fixed in
    4.7.4, 4.5.19, 4.6.12

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2012-3530: 1.65% estimated exploitation activity in the next 30 days; percentile 76.52 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Incomplete blacklist vulnerability in the t3libdiv::quoteJSvalue API function in TYPO3 4.5.x before 4.5.19, 4.6.x before 4.6.12 and 4.7.x before 4.7.4 allows remote attackers to conduct cross-site scripting (XSS) attacks via certain HTML5 JavaScript events.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-94c2-g68f-9r98

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2012-3530

Advisory: Typo3 API XSS Vulnerability
IDs: CVE-2012-3530, GHSA-94c2-g68f-9r98
Record: https://patchnext.com/advisories/cve-2012-3530 (revision 1, source checked 26 Oct 2026, 14:14 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: typo3/cms 4.7.4, 4.6.12, 4.5.19. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist typo3/cms: affected >= 4.5, < 4.5.19; >= 4.6, < 4.6.12; >= 4.7, < 4.7.4; fixed in 4.7.4, 4.5.19, 4.6.12

## Suggested inspection (read-only)
- Packagist typo3/cms: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on typo3/cms.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-94c2-g68f-9r98 (GitHub-reviewed advisory GHSA-94c2-g68f-9r98 lists affected ranges: Packagist typo3/cms >=4.5 =4.6 =4.7 <4.7.4)

Commands are suggestions: review each one before running it.

Loading voting…