Skip to content

← Actionable
High, CVSS 8.7

GeSHi vulnerable to Directory Traversal

CVE-2012-3521GHSA-fw3x-2pr2-5j64

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (geshi/geshi 1.0.8.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist geshi/geshi

    Affected
    < 1.0.8.11
    Fixed in
    1.0.8.11

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
8.7 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2012-3521: 3.17% estimated exploitation activity in the next 30 days; percentile 88.06 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Multiple directory traversal vulnerabilities in the cssgen contrib module in GeSHi before 1.0.8.11 allow remote attackers to read arbitrary files via a .. (dot dot) in the (1) geshi-path or (2) geshi-lang-path parameter.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-fw3x-2pr2-5j64

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2012-3521

Advisory: GeSHi vulnerable to Directory Traversal
IDs: CVE-2012-3521, GHSA-fw3x-2pr2-5j64
Record: https://patchnext.com/advisories/cve-2012-3521 (revision 1, source checked 26 Oct 2026, 14:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: High (CVSS 8.7)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: geshi/geshi 1.0.8.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist geshi/geshi: affected < 1.0.8.11; fixed in 1.0.8.11

## Suggested inspection (read-only)
- Packagist geshi/geshi: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on geshi/geshi.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-fw3x-2pr2-5j64 (GitHub-reviewed advisory GHSA-fw3x-2pr2-5j64 lists affected ranges: Packagist geshi/geshi >=0 <1.0.8.11)

Commands are suggestions: review each one before running it.

Loading voting…