Skip to content

← Actionable
Unrated

actionpack Improper Authentication vulnerability

CVE-2012-3424GHSA-92w9-2pqw-rhjj

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (actionpack 3.2.7, 3.1.7, 3.0.16, 2.3.5), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems actionpack

    Affected
    >= 3.1.0, < 3.1.7>= 3.2.0, < 3.2.7>= 3.0.0.beta, < 3.0.16< 2.3.5
    Fixed in
    3.0.16, 3.2.7, 2.3.5, 3.1.7

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2012-3424: 1.89% estimated exploitation activity in the next 30 days; percentile 79.58 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

The decodecredentials method in actionpack/lib/actioncontroller/metal/httpauthentication.rb in Ruby on Rails before 3.0.16, 3.1.x before 3.1.7, and 3.2.x before 3.2.7 converts Digest Authentication strings to symbols, which allows remote attackers to cause a denial of service by leveraging access to an application that uses a withhttpdigest helper method, as demonstrated by the authenticateorrequestwithhttpdigest method.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-92w9-2pqw-rhjj

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2012-3424

Advisory: actionpack Improper Authentication vulnerability
IDs: CVE-2012-3424, GHSA-92w9-2pqw-rhjj
Record: https://patchnext.com/advisories/cve-2012-3424 (revision 1, source checked 26 Oct 2026, 15:48 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: actionpack 3.2.7, 3.1.7, 3.0.16, 2.3.5. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems actionpack: affected >= 3.1.0, < 3.1.7; >= 3.2.0, < 3.2.7; >= 3.0.0.beta, < 3.0.16; < 2.3.5; fixed in 3.0.16, 3.2.7, 2.3.5, 3.1.7

## Suggested inspection (read-only)
- RubyGems actionpack: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on actionpack.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-92w9-2pqw-rhjj (GitHub-reviewed advisory GHSA-92w9-2pqw-rhjj lists affected ranges: RubyGems actionpack >=3.1.0 =3.2.0 =3.0.0.beta =0 <2.3.5)

Commands are suggestions: review each one before running it.

Loading voting…