Drupal improper access restrictions
CVE-2012-2153GHSA-vpm6-h53m-x2xf
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (drupal/drupal 7.14), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist drupal/drupal
- Affected
- >= 7.0, < 7.14
- Fixed in
- 7.14
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-vpm6-h53m-x2xf lists affected ranges: Packagist drupal/drupal >=7.0 <7.14
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2012-2153: 1.88% estimated exploitation activity in the next 30 days; percentile 79.48 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Drupal 7.x before 7.14 does not properly restrict access to nodes in a list when using a "contributed node access module," which allows remote authenticated users with the "Access the content overview page" permission to read all published nodes by accessing the admin/content page.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-vpm6-h53m-x2xf
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2012-2153 Advisory: Drupal improper access restrictions IDs: CVE-2012-2153, GHSA-vpm6-h53m-x2xf Record: https://patchnext.com/advisories/cve-2012-2153 (revision 1, source checked 26 Oct 2026, 14:09 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: drupal/drupal 7.14. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist drupal/drupal: affected >= 7.0, < 7.14; fixed in 7.14 ## Suggested inspection (read-only) - Packagist drupal/drupal: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on drupal/drupal. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-vpm6-h53m-x2xf (GitHub-reviewed advisory GHSA-vpm6-h53m-x2xf lists affected ranges: Packagist drupal/drupal >=7.0 <7.14) Commands are suggestions: review each one before running it.
Loading voting…