RubyGems does not verify SSL certificate
CVE-2012-2126GHSA-5mgj-mvv8-46mw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (rubygems-update 1.8.23), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems rubygems-update
- Affected
- < 1.8.23
- Fixed in
- 1.8.23
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-5mgj-mvv8-46mw lists affected ranges: RubyGems rubygems-update >=0 <1.8.23
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2012-2126: 1.36% estimated exploitation activity in the next 30 days; percentile 71.80 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
RubyGems before 1.8.23 does not verify an SSL certificate, which allows remote attackers to modify a gem during installation via a man-in-the-middle attack.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-5mgj-mvv8-46mw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2012-2126 Advisory: RubyGems does not verify SSL certificate IDs: CVE-2012-2126, GHSA-5mgj-mvv8-46mw Record: https://patchnext.com/advisories/cve-2012-2126 (revision 1, source checked 26 Oct 2026, 15:47 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: rubygems-update 1.8.23. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems rubygems-update: affected < 1.8.23; fixed in 1.8.23 ## Suggested inspection (read-only) - RubyGems rubygems-update: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on rubygems-update. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-5mgj-mvv8-46mw (GitHub-reviewed advisory GHSA-5mgj-mvv8-46mw lists affected ranges: RubyGems rubygems-update >=0 <1.8.23) Commands are suggestions: review each one before running it.
Loading voting…