Apache Hadoop allows impersonation of arbitrary cluster user accounts
CVE-2012-1574GHSA-c6f9-4pmv-m7m6
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.hadoop:hadoop-main 1.0.2, 0.23.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.hadoop:hadoop-main
- Affected
- >= 0.23, < 0.23.2>= 1.0, < 1.0.2
- Fixed in
- 1.0.2, 0.23.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-c6f9-4pmv-m7m6 lists affected ranges: Maven org.apache.hadoop:hadoop-main >=0.23 =1.0 <1.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2012-1574: 4.77% estimated exploitation activity in the next 30 days; percentile 91.92 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The Kerberos/MapReduce security functionality in Apache Hadoop 0.20.203.0 through 0.20.205.0, 0.23.x before 0.23.2, and 1.0.x before 1.0.2, as used in Cloudera CDH CDH3u0 through CDH3u2, Cloudera hadoop-0.20-sbin before 0.20.2+923.197, and other products, allows remote authenticated users to impersonate arbitrary cluster user accounts via unspecified vectors.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-c6f9-4pmv-m7m6
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2012-1574 Advisory: Apache Hadoop allows impersonation of arbitrary cluster user accounts IDs: CVE-2012-1574, GHSA-c6f9-4pmv-m7m6 Record: https://patchnext.com/advisories/cve-2012-1574 (revision 1, source checked 26 Oct 2026, 16:12 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.hadoop:hadoop-main 1.0.2, 0.23.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.hadoop:hadoop-main: affected >= 0.23, < 0.23.2; >= 1.0, < 1.0.2; fixed in 1.0.2, 0.23.2 ## Suggested inspection (read-only) - Maven org.apache.hadoop:hadoop-main: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.hadoop:hadoop-main. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-c6f9-4pmv-m7m6 (GitHub-reviewed advisory GHSA-c6f9-4pmv-m7m6 lists affected ranges: Maven org.apache.hadoop:hadoop-main >=0.23 =1.0 <1.0.2) Commands are suggestions: review each one before running it.
Loading voting…