Elefant CMS Multiple XSS Vulnerabilities
CVE-2012-1296GHSA-qjjq-rcq8-jw6j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (elefant/cms 1.1.5-Beta, 1.0.2-Beta), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist elefant/cms
- Affected
- >= 1.0, < 1.0.2-Beta>= 1.1, < 1.1.5-Beta
- Fixed in
- 1.0.2-Beta, 1.1.5-Beta
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-qjjq-rcq8-jw6j lists affected ranges: Packagist elefant/cms >=1.0 =1.1 <1.1.5-Beta
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2012-1296: 1.28% estimated exploitation activity in the next 30 days; percentile 70.14 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Multiple cross-site scripting (XSS) vulnerabilities in apps/admin/handlers/preview.php in Elefant CMS 1.0.x before 1.0.2-Beta and 1.1.x before 1.1.5-Beta allow remote attackers to inject arbitrary web script or HTML via the (1) title or (2) body parameter to admin/preview.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-qjjq-rcq8-jw6j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2012-1296 Advisory: Elefant CMS Multiple XSS Vulnerabilities IDs: CVE-2012-1296, GHSA-qjjq-rcq8-jw6j Record: https://patchnext.com/advisories/cve-2012-1296 (revision 1, source checked 26 Oct 2026, 14:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: elefant/cms 1.1.5-Beta, 1.0.2-Beta. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist elefant/cms: affected >= 1.0, < 1.0.2-Beta; >= 1.1, < 1.1.5-Beta; fixed in 1.0.2-Beta, 1.1.5-Beta ## Suggested inspection (read-only) - Packagist elefant/cms: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on elefant/cms. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-qjjq-rcq8-jw6j (GitHub-reviewed advisory GHSA-qjjq-rcq8-jw6j lists affected ranges: Packagist elefant/cms >=1.0 =1.1 <1.1.5-Beta) Commands are suggestions: review each one before running it.
Loading voting…