Moodle default permissions too permissive
CVE-2012-1157GHSA-2x36-7xfm-pgm7
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 2.2.2, 2.1.5, 2.0.8, 1.9.17), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- >= 2.2, <= 2.2.1>= 2.1, <= 2.1.4>= 2.0, <= 2.0.7< 1.9.17
- Fixed in
- 1.9.17, 2.1.5, 2.2.2, 2.0.8
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-2x36-7xfm-pgm7 lists affected ranges: Packagist moodle/moodle >=2.2 =2.1 =2.0 =0 <1.9.17
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- 4.3 · CVSS:3.1/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N
- EPSS
- CVE-2012-1157: 1.22% estimated exploitation activity in the next 30 days; percentile 68.63 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Moodle before 2.2.2 default settings allowed all repositories to be viewable by all authenticated users.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-2x36-7xfm-pgm7
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2012-1157 Advisory: Moodle default permissions too permissive IDs: CVE-2012-1157, GHSA-2x36-7xfm-pgm7 Record: https://patchnext.com/advisories/cve-2012-1157 (revision 1, source checked 26 Oct 2026, 14:14 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 4.3) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 2.2.2, 2.1.5, 2.0.8, 1.9.17. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected >= 2.2, <= 2.2.1; >= 2.1, <= 2.1.4; >= 2.0, <= 2.0.7; < 1.9.17; fixed in 1.9.17, 2.1.5, 2.2.2, 2.0.8 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-2x36-7xfm-pgm7 (GitHub-reviewed advisory GHSA-2x36-7xfm-pgm7 lists affected ranges: Packagist moodle/moodle >=2.2 =2.1 =2.0 =0 <1.9.17) Commands are suggestions: review each one before running it.
Loading voting…