PHPMailer vulnerable to email header injection
CVE-2012-0796GHSA-398j-f7m7-795j
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (phpmailer/phpmailer 2.2.1), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist phpmailer/phpmailer
- Affected
- < 2.2.1
- Fixed in
- 2.2.1
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-398j-f7m7-795j lists affected ranges: Packagist phpmailer/phpmailer >=0 <2.2.1
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2012-0796: 1.68% estimated exploitation activity in the next 30 days; percentile 76.91 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Impact Arbitrary additional email headers can be injected via crafted From or Sender headers. Patches Fixed in 2.2.1 Workarounds Filter user-supplied values prior to using them in From or Sender properties. References https://nvd.nist.gov/vuln/detail/CVE-2012-0796 For more information If you have any questions or comments about this advisory: Open a private issue in the PHPMailer project
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-398j-f7m7-795j
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2012-0796 Advisory: PHPMailer vulnerable to email header injection IDs: CVE-2012-0796, GHSA-398j-f7m7-795j Record: https://patchnext.com/advisories/cve-2012-0796 (revision 1, source checked 26 Oct 2026, 14:10 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: phpmailer/phpmailer 2.2.1. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist phpmailer/phpmailer: affected < 2.2.1; fixed in 2.2.1 ## Suggested inspection (read-only) - Packagist phpmailer/phpmailer: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on phpmailer/phpmailer. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-398j-f7m7-795j (GitHub-reviewed advisory GHSA-398j-f7m7-795j lists affected ranges: Packagist phpmailer/phpmailer >=0 <2.2.1) Commands are suggestions: review each one before running it.
Loading voting…