Denial of Service in Apache Tomcat
CVE-2012-0022GHSA-8h2q-qm9x-55jc
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat 7.0.23, 6.0.34, 5.5.35), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Maven org.apache.tomcat:tomcat
- Affected
- >= 5.5.0, < 5.5.35>= 6.0.0, < 6.0.34>= 7.0.0, < 7.0.23
- Fixed in
- 6.0.34, 7.0.23, 5.5.35
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-8h2q-qm9x-55jc lists affected ranges: Maven org.apache.tomcat:tomcat >=5.5.0 =6.0.0 =7.0.0 <7.0.23
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2012-0022: 10.48% estimated exploitation activity in the next 30 days; percentile 95.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Apache Tomcat 5.5.x before 5.5.35, 6.x before 6.0.34, and 7.x before 7.0.23 uses an inefficient approach for handling parameters, which allows remote attackers to cause a denial of service (CPU consumption) via a request that contains many parameters and parameter values, a different vulnerability than CVE-2011-4858.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-8h2q-qm9x-55jc
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2012-0022 Advisory: Denial of Service in Apache Tomcat IDs: CVE-2012-0022, GHSA-8h2q-qm9x-55jc Record: https://patchnext.com/advisories/cve-2012-0022 (revision 1, source checked 26 Oct 2026, 16:26 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat 7.0.23, 6.0.34, 5.5.35. A vendor fix does not mean a deployment is fixed. ## Affected components - Maven org.apache.tomcat:tomcat: affected >= 5.5.0, < 5.5.35; >= 6.0.0, < 6.0.34; >= 7.0.0, < 7.0.23; fixed in 6.0.34, 7.0.23, 5.5.35 ## Suggested inspection (read-only) - Maven org.apache.tomcat:tomcat: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on org.apache.tomcat:tomcat. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-8h2q-qm9x-55jc (GitHub-reviewed advisory GHSA-8h2q-qm9x-55jc lists affected ranges: Maven org.apache.tomcat:tomcat >=5.5.0 =6.0.0 =7.0.0 <7.0.23) Commands are suggestions: review each one before running it.
Loading voting…