Celery local privilege escalation vulnerability
CVE-2011-4356GHSA-rpc6-h455-3rx5
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (celery 2.4.4, 2.3.4, 2.2.8), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
PyPI celery
- Affected
- >= 2.1.0, < 2.2.8>= 2.3.0, < 2.3.4>= 2.4.0, < 2.4.4
- Fixed in
- 2.2.8, 2.3.4, 2.4.4
Sources
- Open Source Vulnerabilities (OSV.dev), including the GitHub Advisory Database
OSV record GHSA-rpc6-h455-3rx5 lists affected ranges: PyPI celery >=2.1.0 =2.3.0 =2.4.0 <2.4.4 (fixed)
VerifiedObserved Structured OSV record; GitHub-reviewed advisory.
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-rpc6-h455-3rx5 lists affected ranges: PyPI celery >=2.1.0 =2.3.0 =2.4.0 <2.4.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2011-4356: 0.33% estimated exploitation activity in the next 30 days; percentile 26.21 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
Celery 2.1 and 2.2 before 2.2.8, 2.3 before 2.3.4, and 2.4 before 2.4.4 changes the effective id but not the real id during processing of the --uid and --gid arguments to celerybeat, celeryddetach, celeryd-multi, and celeryev, which allows local users to gain privileges via vectors involving crafted code that is executed by the worker process.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 2 · amended ·
Amended from ghsa record GHSA-rpc6-h455-3rx5
- Revision 1 · created ·
Published from osv record GHSA-rpc6-h455-3rx5
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2011-4356 Advisory: Celery local privilege escalation vulnerability IDs: CVE-2011-4356, GHSA-rpc6-h455-3rx5 Record: https://patchnext.com/advisories/cve-2011-4356 (revision 2, source checked 26 Oct 2026, 13:16 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: celery 2.4.4, 2.3.4, 2.2.8. A vendor fix does not mean a deployment is fixed. ## Affected components - PyPI celery: affected >= 2.1.0, < 2.2.8; >= 2.3.0, < 2.3.4; >= 2.4.0, < 2.4.4; fixed in 2.2.8, 2.3.4, 2.4.4 ## Suggested inspection (read-only) - `python -m pip show celery`: prints the installed version. Run with the environment that serves production active. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on celery. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://osv.dev/vulnerability/GHSA-rpc6-h455-3rx5 (OSV record GHSA-rpc6-h455-3rx5 lists affected ranges: PyPI celery >=2.1.0 =2.3.0 =2.4.0 <2.4.4 (fixed)) - Verified: https://github.com/advisories/GHSA-rpc6-h455-3rx5 (GitHub-reviewed advisory GHSA-rpc6-h455-3rx5 lists affected ranges: PyPI celery >=2.1.0 =2.3.0 =2.4.0 <2.4.4) Commands are suggestions: review each one before running it.
Loading voting…