Moodle does not force password changes for autosubscribed users
CVE-2011-4287GHSA-j3x5-cwfj-pfcw
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 2.0.2), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
Packagist moodle/moodle
- Affected
- >= 2.0.0, < 2.0.2
- Fixed in
- 2.0.2
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-j3x5-cwfj-pfcw lists affected ranges: Packagist moodle/moodle >=2.0.0 <2.0.2
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS 4.0
- 6.9 · CVSS:4.0/AV:N/AC:H/AT:P/PR:N/UI:N/VC:H/VI:H/VA:N/SC:N/SI:N/SA:N/E:U · score source
- EPSS
- CVE-2011-4287: 2.07% estimated exploitation activity in the next 30 days; percentile 81.41 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
admin/uploaduserform.php in Moodle 2.0.x before 2.0.3 does not force password changes for autosubscribed users, which makes it easier for remote attackers to obtain access by leveraging knowledge of the initial password of a new user.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-j3x5-cwfj-pfcw
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2011-4287 Advisory: Moodle does not force password changes for autosubscribed users IDs: CVE-2011-4287, GHSA-j3x5-cwfj-pfcw Record: https://patchnext.com/advisories/cve-2011-4287 (revision 1, source checked 26 Oct 2026, 14:30 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Medium (CVSS 6.9) Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 2.0.2. A vendor fix does not mean a deployment is fixed. ## Affected components - Packagist moodle/moodle: affected >= 2.0.0, < 2.0.2; fixed in 2.0.2 ## Suggested inspection (read-only) - Packagist moodle/moodle: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on moodle/moodle. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-j3x5-cwfj-pfcw (GitHub-reviewed advisory GHSA-j3x5-cwfj-pfcw lists affected ranges: Packagist moodle/moodle >=2.0.0 <2.0.2) Commands are suggestions: review each one before running it.
Loading voting…