Skip to content

← Actionable
Medium, CVSS 6.6

Moodle allows remote attackers to obtain sensitive information

CVE-2011-4283GHSA-m3xp-4hf3-qfpp

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (moodle/moodle 2.0.2, 1.9.11), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Packagist moodle/moodle

    Affected
    >= 1.9.0, < 1.9.11>= 2.0.0, < 2.0.2
    Fixed in
    1.9.11, 2.0.2

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
6.6 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:N/VA:N/SC:N/SI:N/SA:N/E:U · score source
EPSS
  • CVE-2011-4283: 2.12% estimated exploitation activity in the next 30 days; percentile 81.87 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Moodle 1.9.x before 1.9.11 and 2.0.x before 2.0.2 places an IMS enterprise enrolment file in the course-files area, which allows remote attackers to obtain sensitive information via a request for imsenterprise-enrol.xml.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-m3xp-4hf3-qfpp

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2011-4283

Advisory: Moodle allows remote attackers to obtain sensitive information
IDs: CVE-2011-4283, GHSA-m3xp-4hf3-qfpp
Record: https://patchnext.com/advisories/cve-2011-4283 (revision 1, source checked 26 Oct 2026, 14:30 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Medium (CVSS 6.6)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: moodle/moodle 2.0.2, 1.9.11. A vendor fix does not mean a deployment is fixed.

## Affected components
- Packagist moodle/moodle: affected >= 1.9.0, < 1.9.11; >= 2.0.0, < 2.0.2; fixed in 1.9.11, 2.0.2

## Suggested inspection (read-only)
- Packagist moodle/moodle: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on moodle/moodle.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-m3xp-4hf3-qfpp (GitHub-reviewed advisory GHSA-m3xp-4hf3-qfpp lists affected ranges: Packagist moodle/moodle >=1.9.0 =2.0.0 <2.0.2)

Commands are suggestions: review each one before running it.

Loading voting…