Skip to content

← Actionable
Unrated

Apache Tomcat Allows Remote Attackers to Spoof AJP Requests

CVE-2011-3190GHSA-c38m-v4m2-524v

What to do

Vendor fix available. Upgrade each affected package to the fixed version on its release line (org.apache.tomcat:tomcat 7.0.21, 6.0.34, 5.5.34), redeploy, then verify what is actually installed.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • Maven org.apache.tomcat:tomcat

    Affected
    >= 7.0.0, <= 7.0.20>= 6.0.0, <= 6.0.33>= 5.0.0, <= 5.5.33
    Fixed in
    6.0.34, 7.0.21, 5.5.34

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS
not scored
EPSS
  • CVE-2011-3190: 15.23% estimated exploitation activity in the next 30 days; percentile 96.76 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Certain AJP protocol connector implementations in Apache Tomcat 7.0.0 through 7.0.20, 6.0.0 through 6.0.33, 5.5.0 through 5.5.33, and possibly other versions allow remote attackers to spoof AJP requests, bypass authentication, and obtain sensitive information by causing the connector to interpret a request body as a new request.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-c38m-v4m2-524v

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2011-3190

Advisory: Apache Tomcat Allows Remote Attackers to Spoof AJP Requests
IDs: CVE-2011-3190, GHSA-c38m-v4m2-524v
Record: https://patchnext.com/advisories/cve-2011-3190 (revision 1, source checked 26 Oct 2026, 16:26 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Unrated
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Vendor fix available; fixed versions by package: org.apache.tomcat:tomcat 7.0.21, 6.0.34, 5.5.34. A vendor fix does not mean a deployment is fixed.

## Affected components
- Maven org.apache.tomcat:tomcat: affected >= 7.0.0, <= 7.0.20; >= 6.0.0, <= 6.0.33; >= 5.0.0, <= 5.5.33; fixed in 6.0.34, 7.0.21, 5.5.34

## Suggested inspection (read-only)
- Maven org.apache.tomcat:tomcat: check the installed version with your package manager.

## Supported action
Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on org.apache.tomcat:tomcat.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-c38m-v4m2-524v (GitHub-reviewed advisory GHSA-c38m-v4m2-524v lists affected ranges: Maven org.apache.tomcat:tomcat >=7.0.0 =6.0.0 =5.0.0 <=5.5.33)

Commands are suggestions: review each one before running it.

Loading voting…