Skip to content

← Actionable
Critical, CVSS 9.3

Spree Commerce is vulnerable to RCE through Search API

CVE-2011-10026GHSA-x485-rhg3-cqr4

What to do

Partial vendor fix. Follow the primary source's mitigation guidance and check back for a fix.

This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.

Affected packages

  • RubyGems rd_searchlogic

    Affected
    <= 3.0.1
    Fixed in
    no fixed version recorded
  • RubyGems spree

    Affected
    >= 0.30.0.beta1, < 0.50.0
    Fixed in
    0.50.0

Sources

Severity and exploitation
Exploitation
No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
CVSS 4.0
9.3 · CVSS:4.0/AV:N/AC:L/AT:N/PR:N/UI:N/VC:H/VI:H/VA:H/SC:N/SI:N/SA:N · score source
EPSS
  • CVE-2011-10026: 3.76% estimated exploitation activity in the next 30 days; percentile 89.90 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description

As published by the source; long descriptions are shortened.

Spreecommerce versions prior to 0.50.x contain a remote command execution vulnerability in the API's search functionality. Improper input sanitation allows attackers to inject arbitrary shell commands via the search[instanceeval] parameter, which is dynamically invoked using Ruby’s send method. This flaw enables unauthenticated attackers to execute commands on the server.

Dates and revisions
Published by the source
Last modified by the source
Source last checked
  1. Revision 1 · created ·

    Published from ghsa record GHSA-x485-rhg3-cqr4

Agent brief

Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.

# Patch Next advisory brief: CVE-2011-10026

Advisory: Spree Commerce is vulnerable to RCE through Search API
IDs: CVE-2011-10026, GHSA-x485-rhg3-cqr4
Record: https://patchnext.com/advisories/cve-2011-10026 (revision 1, source checked 26 Oct 2026, 15:51 UTC)
Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected.
Severity: Critical (CVSS 9.3)
Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV.
Vendor response: Partial vendor fix; fixed versions by package: spree 0.50.0. A vendor fix does not mean a deployment is fixed.

## Affected components
- RubyGems rd_searchlogic: affected <= 3.0.1
- RubyGems spree: affected >= 0.30.0.beta1, < 0.50.0; fixed in 0.50.0

## Suggested inspection (read-only)
- RubyGems rd_searchlogic: check the installed version with your package manager.
- RubyGems spree: check the installed version with your package manager.

## Supported action
No complete vendor fix is recorded. Follow the primary source's mitigation guidance and check this record again before closing anything.

## Required regression checks
- Run the test suite and a production build.
- Exercise the features that depend on rd_searchlogic, spree.
- Repeat the inspection and confirm that only fixed versions remain installed.

## Rollback considerations
- Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward.

## Unresolved questions
- Which deployments run an affected version?
- Exploitation status can change. Check again before lowering the priority.
- Mark the work resolved only after the fixed version is verified in production.

## Sources
- Verified: https://github.com/advisories/GHSA-x485-rhg3-cqr4 (GitHub-reviewed advisory GHSA-x485-rhg3-cqr4 lists affected ranges: RubyGems spree >=0.30.0.beta1 =0 <=3.0.1)

Commands are suggestions: review each one before running it.

Loading voting…