sqlite3-ruby uses weak permissions for unspecified files, which allows local users to gain privileges
CVE-2011-0995GHSA-6x46-7rrv-m4h8
What to do
Vendor fix available. Upgrade each affected package to the fixed version on its release line (sqlite3-ruby 1.2.4), redeploy, then verify what is actually installed.
This page has no inventory attached, so it cannot say whether you are affected. A vendor fix is not proof that your deployment is fixed.
Affected packages
RubyGems sqlite3-ruby
- Affected
- < 1.2.4
- Fixed in
- 1.2.4
Sources
- GitHub Advisory Database and maintainer security advisories on GitHub
GitHub-reviewed advisory GHSA-6x46-7rrv-m4h8 lists affected ranges: RubyGems sqlite3-ruby >=0 <1.2.4
VerifiedObserved Structured GitHub Advisory Database record (type=reviewed) from the GitHub REST API.
Severity and exploitation
- Exploitation
- No confirmed exploitation recorded. Patch Next marks exploitation only from CISA KEV.
- CVSS
- not scored
- EPSS
- CVE-2011-0995: 0.38% estimated exploitation activity in the next 30 days; percentile 31.83 (FIRST EPSS, 2026-11-03). This is a model estimate, not proof of exploitation or customer exposure.
Source description
As published by the source; long descriptions are shortened.
The sqlite3-ruby gem in the rubygem-sqlite3 package before 1.2.4-0.5.1 in SUSE Linux Enterprise (SLE) 11 SP1 uses weak permissions for unspecified files, which allows local users to gain privileges via unknown vectors.
Dates and revisions
- Published by the source
- Last modified by the source
- Source last checked
- Revision 1 · created ·
Published from ghsa record GHSA-6x46-7rrv-m4h8
Agent brief
Preview the exact text before you copy it. Commands are read-only suggestions; review them before running anything.
# Patch Next advisory brief: CVE-2011-0995 Advisory: sqlite3-ruby uses weak permissions for unspecified files, which allows local users to gain privileges IDs: CVE-2011-0995, GHSA-6x46-7rrv-m4h8 Record: https://patchnext.com/advisories/cve-2011-0995 (revision 1, source checked 26 Oct 2026, 15:48 UTC) Inventory: none attached. This brief comes from a public page and does not say whether any deployment is affected. Severity: Unrated Exploitation: no confirmed exploitation recorded. Patch Next confirms exploitation only from CISA KEV. Vendor response: Vendor fix available; fixed versions by package: sqlite3-ruby 1.2.4. A vendor fix does not mean a deployment is fixed. ## Affected components - RubyGems sqlite3-ruby: affected < 1.2.4; fixed in 1.2.4 ## Suggested inspection (read-only) - RubyGems sqlite3-ruby: check the installed version with your package manager. ## Supported action Upgrade each affected component to a fixed version on its release line. For a transitive dependency, upgrade the parent package or add an override or constraint, then regenerate the lockfile. Redeploy every environment that ran an affected version. ## Required regression checks - Run the test suite and a production build. - Exercise the features that depend on sqlite3-ruby. - Repeat the inspection and confirm that only fixed versions remain installed. ## Rollback considerations - Keep the previous lockfile and deployment artifact. Rolling back reinstates the vulnerable version, so apply any documented mitigation while you fix forward. ## Unresolved questions - Which deployments run an affected version? - Exploitation status can change. Check again before lowering the priority. - Mark the work resolved only after the fixed version is verified in production. ## Sources - Verified: https://github.com/advisories/GHSA-6x46-7rrv-m4h8 (GitHub-reviewed advisory GHSA-6x46-7rrv-m4h8 lists affected ranges: RubyGems sqlite3-ruby >=0 <1.2.4) Commands are suggestions: review each one before running it.
Loading voting…